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Ultra Global Simulator  
- Tutorial 

 

 
 
What it does 
Our ATS/Citymobil software enables you to quickly and easily design an Ultra system in an area of 
your choosing and see how it performs. You can: 
 

- Get started with one of our example networks or build your own network using a 
background map 

- Edit networks by changing interconnections and adding or removing stations 
- Set the level of demand at each station and let the simulator construct an origin-destination 

demand matrix, or enter your own demand matrix 
- Run simulations in real time or much faster than real time 
- See how the individual vehicles are controlled to wait at stations until passengers arrive and 

then directed to the requested destination station 
- See how empty vehicles are called to stations if passengers have arrived but no vehicle is 

waiting 
- See how many passengers are waiting at each station see how many vehicles are at each 

station, waiting empty, unloading or loading passengers 
- See the mean waiting time at each station and overall, and the number of vehicles required 

 
How to Install 
ATS/CityMobil runs on all recent Windows PCs. 
 

1. Download the simulator (20MB .EXE) by clicking on the hyperlink. 
2. Run the installer program. 
3. The installer will launch the program when it finishes; to run the tool again, use the ATS 

CityMobil link in the Start Menu, under Programs. 
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How to Use: Tutorial 
When you run ATS/CityMobil, you will first be shown the start-up 
window (shown to the right). Before creating a new network, it is 
helpful to understand how the simulation works by looking at an 
existing network design. 
 
Click Open Case Study with either Urban Case Study or Airport Case 
Study highlighted. The network you have selected will appear on the 
screen (shown below). The PRT guideway is represented by thick 
black lines, with passenger access points (stations) depicted as blue 
circles and vehicle storage depots shown as yellow diamonds. The 
direction of flow is shown by white triangles. 
 
 

Click View in the main menu at the top of the 
screen, and use the commands there to look 
more closely at the selected case study. You can 
also use the mouse or keyboard to change the 
view. Right click and drag, or use the cursor 
keys, to move around. Use the mouse wheel, or 
the square bracket keys ] [, to zoom in and out. 
 
Click Run in the top left hand corner of the 
screen. After a short time you will see vehicles 
moving around – these are represented by 
green and red spots on the screen. The 
simulation is initially set to run in real time. To 
speed up operation of the simulation, click on 
Faster, which will appear in the top right hand 
corner of the screen. If the simulation does not 
run, you may have inadvertently altered the 
network. The green tick at top right shows 

whether the network is complete. If not, try reloading the network (from the File menu) and try 
again. 
 
The Simulator Display 
The simulation runs for a greatly accelerated 30 
minutes unseen before the screen display 
opens, so that the system is fully loaded. 
 
At stations, vehicle berths are shown as small 
circles. Empty berths are white. Vehicles waiting 
at berths are coloured according to the vehicle 
colour key, shown at bottom right of the screen: 
 

 Green: When passengers board a 
vehicle it becomes green in a station, 
and once boarding is finished the vehicle 
automatically starts its journey and is 
displayed as a green moving spot. 
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 Blue: When an occupied (green) vehicle reaches its destination, it usually takes around a half 
a minute for the passenger(s) to disembark. The vehicle’s colour is changed to blue during 
this unloading phase. 

 Red: Once the vehicle has been unloaded, it is ready to carry another passenger, and is 
coloured red as it either waits in the station or is moved to another station or back to a 
depot. 

 Grey: Sometimes occupied vehicles have to wait momentarily in a station for a time slot to 
be cleared throughout their journey and are coloured grey while waiting. 

 
In times of low passenger demand, many empty vehicles can be seen waiting in the stations. If a 
passenger arrives and begins boarding a vehicle, that vehicle’s colour will change to green. Normally 
the boarding process takes about a (variable) half a minute, so you can see a number of stationary 
vehicles displayed in green at any moment. This can be hard to see if the simulation is running 
quickly. If a passenger should arrive at a station with no empty vehicle available, that passenger 
must wait until a vehicle arrives. 
 
Waiting passengers are shown by a numerical display at each station – this is zero if no passengers 
are currently waiting. The timing of each passenger arrival is completely random. This is controlled 
by a random number generator within the software and is an important part of the simulation. More 
detail about passenger demand levels is given below. Each "passenger" represented by the 
simulation is in fact a group of passengers travelling together, and up to four people can be carried 
in each vehicle. 
 
Moving vehicles all travel at identical speeds and are automatically 
controlled by the ‘synchronous’ control method. Every journey is 
given a uniquely different timing so that vehicles always arrive at 
merges with adequate separation between them, at a minimum 3 
second headway. This may be hard to see at certain magnifications 
– zoom in to see what’s really happening at the merges. The 
vehicles keep going until they reach the passenger’s chosen 
destination; they do not stop at any intermediate stations on 
route. 
 

All the stations (and depots) are assumed to be ‘off-line’ i.e. the 
loading/unloading berths are physically separated from the 
guideway. Thus vehicles can continue travelling past the station at 
full speed without affecting the vehicles parked at the station or 
the passengers getting on and off. Stations can be of any size and shape in order to integrate with 
existing architectural features – this is not represented on the screen display. In the simulation, all 
the stations are represented as idealised circular shapes. While the software does not allow detailed 
station design, the guideway lengths, journey distances and times are all accurately represented. 
 
Each station shown on the screen has up to five vehicle berths, which are displayed as white spaces 
if there is no vehicle currently parked in them. (Actual Ultra stations can have more than five berths, 
but this requires a more complex simulator). Note that when vehicles occupy the berths, their 
positions are not displayed realistically because the berth displays are filled clockwise – if only one 
vehicle is present in the station, the least clockwise berth display will be illuminated, if two vehicles 
are present the two least clockwise displays are illuminated and so on. When one vehicle leaves or 
arrives at a station, it may appear that the remaining vehicles move along from one berth display to 
the next. This is a product of the display only, and is not representative of the way a station operates 
in practice. 
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When running, the screen shows the elapsed time and a running average of passenger wait time at 
bottom left. The distance scale and key to the vehicle colours is at bottom right. Holding the cursor 
over a station brings up a box summarising the current status of the station. At top right, Fast 
Forward turns off the dynamic display and calculates the rest of the simulated period very rapidly. 
At the end of the 2-hour simulation period, the Results screen summarises the mean wait time at 
each station and overall, the percentage of passenger groups waiting less than 60 seconds, the 
numbers of passenger groups carried, and the number of vehicles used. You can copy these results 
into another program by right clicking on the results table. This simulation does NOT optimise the 
fleet size: it calls up as many vehicles as are required to respond to passenger calls. In practice, fewer 
vehicles might be provided and the mean waiting time would be somewhat longer. Stop (top right) 
stops the simulation at any time, and displays the results collected so far. 
 
The Guideway Editing Tools 
To follow along, open the Editing Demonstration case study by clicking File > Open (the simulation 
has to be stopped first; if you are running a simulation, first click Stop and close the results window). 
 

Click Edit at the top left of the screen. Now you can use 
the mouse to move elements of the network around. 
Place the mouse over part of the network and click and 
drag the network element to a new location. Whole track 
sections can be moved, and nodes can also be moved 
around, whether they are depots, stations, or plain track 
nodes. Track curves can be edited in two ways. Click the 
mouse onto the white square node point by a track curve. 
The node turns green when it is selected. You can then 
drag and drop the corner to a different location. 
Alternatively, once you have selected a particular track 
curve a handle or pair of handles will appear coloured 
orange or magenta. Dragging the orange/magenta handle 

will change the radius of curvature of the track without moving the position of the rest of the track. 
Note that when editing curves on a large network it may be necessary to move to a high zoom 
before the curve radii and handles can be seen. 
 
The Edit menu at the top of the screen allows you to undo or redo editing changes. If you click on a 
station or track section, so that the relevant white squares turn green, this menu also allows you to 
delete the selected item, or you can press the Delete key. In the Editing Demonstration example, if a 
station is deleted there is only one left, and an error message will be given at the top right of the 
screen until another station is inserted. Note that when a track section is clicked so that nodes at 
each end turn green, both nodes and attached track sections will be deleted, i.e. three sections if 
two nodes are highlighted: if a station is centred on one end of the indicated section, it will be 
deleted. It is better to click on a single node and delete it and the two track sections attached on 
either side. 

 
Creating a New Network 
First clear the screen by selecting File > New. After deciding whether or not to save any unsaved 
changes to your own file, you will be prompted to import a background picture. For now, select Do 
not use a map, and click Finish. 
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Click Build at the top left of the 
screen, and you can begin to design 
an Ultra network. First choose 
where you want to put stations. 
Position the mouse appropriately, 
and then click and a dialogue box 
will appear. If you simply click OK, a 
station will appear. There are also 
options to control the relative 
passenger demand at the station by 
using the slider or to make a vehicle 
storage depot instead. You can 
name each station, or simply accept 
the default numbering. Create as 
many stations as you like, up to a 
limit of twenty. 
 

Note that you must have at least two stations and one depot for the network to be viable. Once you 
have the stations in place, you can begin to link them up with guideway. Position the mouse over 
one of the stations, press and hold the left mouse button and move the mouse to an adjacent 
station. If you release the mouse button whilst the mouse is positioned over a station, a section of 
guideway will appear linking the two stations. Alternatively, releasing the mouse button whilst the 
mouse is not positioned over any station will create an intermediate node – the track will appear to 
end at this point. Continue the guideway by positioning the mouse over the end point and dragging 
and dropping the mouse as many times as you like to create complex guideway geometries. All 
guideway is one-way only. It is important to construct complete one-way loops, and where loops 
interconnect to ensure consistent directions of flow. If a network is not complete in this sense, a 
message at top right will red flag the failure. If you have not connected a complete loop, the track 
ends will be a green node with a red border, while connected nodes have a black border. If the gap is 
too small to introduce a new section of track, use the Edit menu to undo the last drawn section, and 
then reconnect. 
 
A demerge (split) can be created by positioning the mouse over the mid-section of a piece of 
guideway, holding the mouse button down and dragging and dropping. To create a merge, click on 
an existing network feature, hold down the mouse button and drag the mouse into a position on the 
mid-section of a piece of guideway. A merge will be created when you release the mouse button. 
Note that it is necessary to have a certain distance between nodes, so you may get an error message 
if you try and create a merge or demerge where there is insufficient space because it is too close to 
another node or station. Use the Edit tool to pull the nodes further apart. If a guideway is drawn 
across an existing guideway it is assumed that it passes under or over that guideway: it connects to it 
only if it is explicitly drawn into a node on the existing guideway. 
 
If you prefer, it is possible to draw the guideway first and add the stations later. If you click the 
mouse on an existing track node (a white square), a dialogue box will appear entitled Node type. 
Choose station or depot, enter a name as appropriate and click OK. Use the same procedure to 
remove unwanted stations from a network – click on the station (or depot) and when the dialogue 
box appears, select Plain Node and click OK. Similarly, an existing station can be renamed. 
The network must contain at least one Vehicle Depot. These must be located on the guideway in the 
same way as a station. 
 



 

a: Ultra Global PRT, 130 Aztec, Aztec West, Bristol, BS32 4UB, United Kingdom 

t:+44(0) 1454 414700 f:+44(0) 1454 414770 w:www.Ultraglobalprt.com 

Once you have finished entering the network try running the simulation. Look at the message in the 
top right hand corner of the screen. It will say All OK if it is possible to run. If it is not possible to run 
the network, you will see an error message here. Click on the button to get more information. If the 
track is overloaded, you will need to reduce demand or change the network to reduce the traffic on 
the congested link. 
 
The network can be saved to files and reopened using the File > Open > Open Saved.... The 
appearance of the network can be changed via the Simulation > Appearance menu. 

 
Background Maps 

It is normally easier to design a network 
if you use a background image, for 
example a map or an aerial photograph. 
It’s best to load this image first. Click File 
> New and this time select Load map 
from a file, then click Browse. Once you 
have found the appropriate image file, 
click Next. It is important to scale the 
map properly before you start drawing 
the network, and several features are 
provided to help with this. You can enter 
the height or the width of the map (in 
km) then click Update. You can also 
enter the scale factor if you prefer. It is 
only necessary to enter one of these 
parameters; click Update and the other 
two parameters will be adjusted 
automatically. Most background images 
are too dark to work with, so adjust the 

Fade slider until the background image is right. When you are satisfied, click Finish. The background 
map of a network can be changed, rescaled or faded at any time via Simulation > Background 
Image. 

 
Passenger Demand Levels 
Passenger demand can be specified in two ways. The first way is to let the simulator distribute the 
demand using a gravity model, based on how you set the Demand sliders provided for each station. 
The second way is to enter a demand matrix, which specifies the number of vehicle trips between 
each pair of stations. 
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To enter or change the demand matrix, select Simulation > Origin-Destination Matrix in the 
Simulation menu. Uncheck the box marked Let the simulator choose the origin-destination matrix, 
and it is then possible to enter numbers directly into the origin-destination table. Origin stations are 
listed in the left hand column, destination stations are listed across the top row. 
 
Click and drag to highlight individual cells, entire rows or columns, or the whole matrix. Right click 
brings up a menu including Scale and Set. Selecting either produces a window in which the 
highlighted numbers can be multiplied by a scale factor, or set to a given value. The number 
travelling into and out of each station is limited to 300 vehicle trips per hour in total. The display will 
turn red and give a warning if you set the demand levels too high. In practice Ultra stations are able 
to accommodate higher demand levels than this; however this requires a more advanced simulator 
to demonstrate. 

 
Empty Vehicle Movements and Fleet Size 
The software automatically moves (red) empty vehicles around to balance the distribution of 
available vehicles. If a loaded vehicle arrives at its destination station and there is no empty berth, 
an empty vehicle at the station may be pushed out to make room for the arriving vehicle, and will 
then be directed to another station where an empty vehicle is required, or back to a depot. 
 
At low levels of demand, each station will be given a minimum of two berths even if the demand 
justifies only one berth, since the second berth represents space for a vehicle to wait, if necessary. 
This simplified simulation will often fill both spaces with empty vehicles, because it operates by 
always answering a passenger call as quickly as possible. For this reason, at low demand this 
simulation tends to over-estimate the fleet size required, and in practice it will be more economical 
to reduce the fleet size and allow mean waiting times to increase slightly, since in these 
circumstances mean wait times will be very low. This trade-off is not available here, but can be 
examined in Ultra PRT's internal simulation tools. 
 
At higher levels of demand, if waiting times are too high, it is a good idea to introduce more depots 
onto the network upstream of stations with unacceptably high waiting times: in practice, these 
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“depots” need be simply storage space for empty vehicles. In this simulation, the same software is 
used to manage empty vehicle movements on all possible different network geometries, so empty 
vehicle circulation might not be optimum on certain types of network. For example, networks with 
small numbers of stations spread over a wide area, or networks with too few depots, may need 
special optimisation to achieve maximum efficiency. The software tools to perform this optimisation 
are not available with this simulation, but are available in Ultra PRT's internal simulation tools.  


